Accueil - Création de site - Message d'erreur en PHP 5.5

Vous avez aimé cet article ? Alors partagez-le avec vos amis en cliquant sur les boutons ci-dessous :

Message d'erreur en PHP 5.5

Si votre hébergeur vous a passé en PHP5.5 vous pouvez avoir des messages d'erreurs soit directement à l'affichage de votre site, soit surtout le plus souvent à la lecture de votre flux RSS et là c'est plus que gênant !
Pourtant i y a bel et bien une solution.
Depuis quelques jours, hébergé sur 1and1, plusieurs messages d'erreurs apparaissent sur différents sites Internet, du genre :
"Strict Standards: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead in /homepages/17/d146008290/htdocs/sfer/core/lib/class.plx.glob.php on line 123".
Au début, interrogation, ensuite inquiétude !!!
Apparemment, ici, dans l'exemple cité, cela ne concerne QUE un script bien précis, hé bien NON !!!
En fait le passage à la version 5.5 de PHP affecte de nombreux scripts qui sont sur le web, et pas seulement que sur cet hébergeur.

Le message d'erreurs.

Il concerne certaine fonctionnalité du langage ' PHP ' devenues obsolètes avec la nouvelle version.
" Ceux " qui savent, ceux qui connaissent le codage au bout des doigts, vont régler tout cela en quelques clics de souris, oui, facile à dire !!!
Mais pour l'instant si vous n'êtes pas de ce Monde, certaines pages, certains scripts ne tournent plus correctement ET surtout la grande majorité des flux RSS deviennent illisibles et de ce fait e sont plus pris par les agrégateurs, tout cela posant et problèmes techniques et problèmes de référencement ...
Mais encore faut-il se préoccuper véritablement de la vie de son site Internet pour s'en rendre compte, et si, par exemple, vous cliquez sur un lien qui mène vers un, ou votre, flux rss, si la page affiche ceci :
message d'erreur PHP
message d'erreur PHP : en php5.5 le flux RSS est illisible
Et là, vous êtes bel est bien ' chocolat bleu pâle ' !!!

Solution en PHP5.5.

Pour remédier à ce genre de problème, surtout dans l'urgence, surtout si vous ne savez pas coder à ce point, il existe trois solutions.
- rechercher sur le Net ce genre de message et voir si à partir de cela vous trouvez la solution à 'votre' problème.
- mettre à jour, si ce n'est pas déjà fait votre script.
La grande majorité du temps, les CMS ou autres scripts bien suivis ont déjà anticipé ce problème, et en oubliant de vous tenir informé, en oubliant de faire votre mise à jour, vous êtes en plein dedans. Normalement dans ce cas, le simple fait d'effectuer une mise à jour de votre site ou de votre site va régler tout cela.
- lancer un 'SOS' auprès d'un maître du genre, ce qui a été fait, et ce qui a donné, via "sebsauvage.net" une solution:
insérer, dans le fichier index.php ou le fichier concerné ( feed.php par exemple ), juste après l'ouverture de 'php' cette simple ligne de code :
 " date_default_timezone_set('Europe/Paris'); "
l'effet est immédiat, le flux est de nouveau lisible, la page tourne de nouveau correctement, mais cela n'est véritablement que la solution d'urgence qui vous permettra de faire tourner votre site correctement, en attendant d'en faire vraiment la mise à jour pour cette version de PHP qui commence à être installée un peu partout chez les gros hébergeurs.

Infos PHP de l'hébergeur.

Et n'oubliez pas:
Toujours suivre les infos, surtout provenant de votre hébergeur ^^
Celui-ci avait prévenu pourtant : " 1and1 et le php5, la cata ", mais en annonçant ce passage au ... 01/04/13 lors du passage en php5.4, mais depuis, pas d'autre nouvelle !!!
Il y avait aussi eu ceci : " mise à jour des serveurs web ", ce concernant qu'un problème technique ' entre le 31/10/2011 et le 04/11/2011 ' et cette dernière modif a bel et bien semé la panique !!!
résultat, on ne sait pas, on oublie et hop, le gros BUG qui affole et surtout qui provoque des blocages ...
Heureusement que sur le Net, existent aussi des gens qui sont vraiment capables, qui sont vraiment des codeurs, qui sont vraiment 'experts' et solidaires !!! comme quoi Internet peut aussi avoir ses bons côtés.
( merci à Stéphane ET à sebsauvage pour cela )
;)
Tous les articles de blog, ainsi que leur contenu, comme indiqué en page index du site principal, sont mis à disposition sous les termes de la licence Creative Commons. Vous pouvez le copier, distribuer et modifier tant que cette note apparaît clairement. " source: longuetraine.fr - Paternité - Pas d'Utilisation Commerciale - Partage des Conditions Initiales à l'Identique 3.0 France ", ainsi qu'un lien vers la source .
à voir également :

1 commentaire

#1  - php a dit :

vu :)
toujours et toujours être au courant de ces modifications !!!
sûr que si l'on ne suit pas, sûr que si l'on ne connait rien de rien au codage là c'est dûr !!!
mais, et c'est très bien dit, il y a aussi des gens désintéressés sur le WEB qui savent donner les bonnes solutions et dépanner les autres, ça c'est très bien vous avez de la chance de les connaître !!!!

Répondre

Fil RSS des commentaires de cet article

Écrire un commentaire

Quelle est la première lettre du mot uifdd ?

Pour laisser un petit avis au passage, nul besoin d'avoir un site ou une adresse Internet, juste se donner un 'pseudo' ...
Les commentaires sont en 'dofollow', mais modérés à priori. Ils ne seront publiés qu'après vérification de votre message.
Si vous pensez ou désirez obtenir un backlink, votre commentaire doit être construit de manière cohérente, rédigé correctement ET avoir un minimum de contenu et de pertinence.